No IPv6 address besides Link-Local one on customer owned modems - Time Warner Internet

#1
This question is about "No IPv6 address besides Link-Local one on customer owned modems", with Time Warner Cable internet and apps. I have been having some issues trying to get IPv6 working. I know everything was working fine some time ago, but I am uncertain when it actually stopped working. I originally had an SB6183 Modem Connected. I noticed a couple of days that my router no longer had an IPv6 Address that was not the Link-Local Address. I did the usual, which was to turn the modem off and on, I still got only an IPv4 address. I turned off and on the WAN interface on the router and I still only got a public IPv4 and the Link-Local address for IPv6. I restarted the router and I got the same thing. I then proceed to test the modem with different hardware. I tested a direct connection on a laptop and still only got an IPv4 address. I tested various options for the dhcp6 client (Prefix Delegation Length, prefix hint, waiting for an RA, disallowing PD/Addresses release) and even different operating systems (Windows 7, Linux, FreeBSD). I finally called Spectrum Tech support and they did some diagnostics on their end. Tech support said they saw some options that they could not change on my modem since it was locked because it is a customer owned device and that they had no way of changing it. They suggested that it was perhaps some firmware or hardware issue and that I should really contact ARRIS Tech support on the issue. Well I did a google search online to see if other people were having issues similar to mine, I saw some threads on forums where they talked about firmware and IPv6 issues with the SB6183. So I talked to ARRIS tech support, they told me that they do not provide firmware to end users but rather the cable company . The cable company is responsible for loading firmware on my device. This is indeed true as the firmware that originally came with the device did in fact change. I am as of now running D30CM-OSPREY-1.5.2.5-GA-00-NOSH on the SB6183 modem. The tech support agent from ARRIS said all he could really suggest was that I perform a factory reset on the modem. I explained that my modem did not have such options on the modem page nor did it have a paper clip hole. He told me to unplug the modem from the coax and restart. With the modem restarted and unpluged from coax the web page allowed me to default it.. Well same issue, I only get a public IPv4 address and the Link-Local address for IPv6. I spoke again with a tech support agent from Spectrum and explained the situation again. This agent was far more knowledgeable and understood that calling ARRIS was pointless as the cable operators are responsible for loading firmware even on customer owned devices. He tried a whole bunch of different things and my modem did power cycle a couple of times but I was still unable to receive an IPv6 address. He said he was sorry and that there was nothing else he knew to do. I said well we tried and gave up for the day. The next day I remote logged into my parent’s network in Texas. They also use an SB6183 and are on Spectrum. Well I notice that they also did not have an IPv6 Address. I then also asked another friend also with an SB6183 and on Spectrum, he also did not have an IPv6 Address. I was then able to look a yet another friend’s setup who has almost identical hardware as me but a different modem. He has a ARRIS Touchstone Modem with this firmware TS0901103J6TW2_072417_16XX.GW_PC20_TW. His modem is actually provided by spectrum and I noticed he correctly gets an IPv6 Address in addition to the Link-Local Address. So yesterday evening I went to the store and decided to just buy a different modem, I saw the ARRIS SB6190 and a Motorola MB7420. I purchased the MB7420 as I read that the SB6190 actually had some issues with firmware and that the chipset. I swapped out modems late last night and got support to help me activate the new modem. I tried doing it online but the activation failed to verify my account number, it wanted a 16-digit account even though in my billing statements they are only 9 digits long. Well I still have no IPv6 here in Raleigh, NC. I did notice though that with this modem (MB7420 7420-5.7.1.19) I get a gateway for IPv6 but it looks like it is a Link Local Address (fe80::217:10ff:fe8b:3918) and of course my Link local address is (fe80::217:3aff:fe80:a25a) As of this moment I am just out of options. I do not know what else to try or do. I guess that approve modem list from spectrum is wrong and that they do not really support IPv6 on all the modems on their list. Help... Any Suggestions?



Best Regards,

Adan

No IPv6 address besides Link-Local one on customer owned modems?
 
Top