No Picture when X1 STB connects to Projector

T

Tmang200

Guest
#1
Hello,



Has anyone recently had issues with getting picture to appear when connecting your X1 STB to a projector? I been using my Sony Bravia projector for years with no issues, and have been using it on a daily basis. Last Friday (12/6/2019), the STB stopped delivering picture to the projector. However, the audio can still be heard through the Bluetooth connection from the STB. Please note, I do not have a Home Theater Audio Receiver connected to the projector - the STB connects directly to the projector via HDMI.



I have tried resetting the STB box (unplugging/re-plugging the power), but when doing so, all I could get to appear on the projector was just the front screen that says Welcome in 3 languages. After that screen, the picture drops and the projector searches for a signal. I tried connecting other devices using the same HDMI cable and they all worked (my MacBook, an Apple TV 4k and an Amazon Fire TV) stick. I than thought maybe it was an issue with the wireless 4K STB I have - so I plugged the STB into an actual Sony HDTV, and the video worked. I than decided to take the projector to my main cable box DVR in the living room to see if that worked - however, that cable box also was also not delivering picture to the projector either! So it appears to be something related with the connection coming from the Comcast STBs in general.



Does anyone have any suggestions? I'm not sure if Comcast recently pushed a firmware update to the X1 boxes or something that maybe could have changed how the video feeds out from the boxes? I'm at lost here. Any help is appreciated!



Thanks!

Ted

"No Picture when X1 STB connects to Projector," is about XFinity-Comcast Television.

For other news regarding No Picture when X1 STB connects to Projector, and XFinity - Comcast Television, see our recommended stories below.
 
Thread starter Similar threads Forum Replies Date
R Comcast 0
5 Comcast 0
S Comcast 0

Similar threads

Top