Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV - XFinity

#1
I hope someone can please please help me. I am having to repeatedly having to uninstall/reinstall/re-authorize/re-activate Xfinity Streaming App on Roku TV. Let me clarify.



My home setup: I subscribe to a 200+ channel Xfinity TV packagre and Xfinity Blast Internet. I provide my own cable modem and wireless router. I have one TV connected to a Xfinity DVR box. I have 4 other TV's using Roku devices with the Xfinty Streaming BETA app.



History: Until about a month ago, Xfintiy Streaming was working fine on all 4 Roku devices and life was great. However, during the last month, things have gone down hill greatly.



The current common scenario: Of the morning, I try to watch Xfinity on a Roku device (usually my TCL TV with built in Roku). When I click on the Xfinity Streaming app, it briefly sits at a blank red screen, then I'm bumped back to the main Roku screen. No matter how many times I then try again, I merely see a red screen and am bumped back to the main Roku screen. So, I then unistall and resinstall and re-authorize the Xfinity Streaming app on the Roku TV. All works beautifully and smoothly. So, I then visit all of the other Roky devices and re-authorize them and they also work smoothly. All is great until the next morning when Xfinity Streaming is no longer working again. . Currently, I am having to uninstall/reinstall/re-authorize/re-activate Xfinity Streaming App on Roku TV nearly every single morning. It's important to clarify now that when Xfintiy is refusing to work, I can still readily/easily/promptly use other streaming services on the Roku such as Hulu/Netflix/YouTube .... so this is clearly not an internet connectivity issue.



What I've tried: Before uninstalling/reinstalling/re-authorizing/re-activating Xfinity Streaming App on Roku TV, I've tried merely rebooting the modem and router. I've tried this more than once but it didn't help at all. I've even totally replaced my router recently, but that didn't help either.



My guess: This 'seems' to perhaps be an issue with the app losing it's authorization/activation????? Again, after I reinstall/re-authorize the app, it works perfectly fine for about 24 hours.

This question, "Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV," is about XFinity-Comcast TV Television Apps.

For other news regarding Repeatedly having to re-authorize/re-activate Xfinity Streaming App on Roku TV, and XFinity - Comcast Television Apps, see our recommended stories below.
 
Top