Stream on Roku goes straight to only the purchases - XFinity

#1
I am beyond frustrated. I've done just about everything. Stream has always worked on my Roku's and out of nowhere it stopped working last week. Did HOURS of support and on the phone with Xfinity and got a new modem. Still didn't work. Finally got it working and then within 24 hours it now will only go to "purchases" page and won't give me any other options. I've again been on the phone with advanced repair for 2 hours. Nothing has worked. We've done factory reset, sent signals to the modem, reinstalled the stream app, logged in with different usernames that are used all to no avail. But it works fine on my laptop or phone or other Roku. I am so done with this. I want what I pay for. I want what has always worked. I work from home and my kids are at home for online school and we can't watch our tv shows like we are supposed to. Please someone help me.

This question, "Stream on Roku goes straight to only the purchases," is about XFinity-Comcast TV Television Apps.

For other news regarding Stream on Roku goes straight to only the purchases, and XFinity - Comcast Television Apps, see our recommended stories below.
 

Similar threads

Top